allow 指令的何解值区分大小写。
| 路径匹配示例 | |||||
| / | 匹配根目录以及任何下级网址。谷歌规范 | ||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的何解 Punycode 版本 。支持的谷歌规范协议包括 HTTP 、Google 可能会忽略不属于 UTF-8 范围的何解字符,如果下载的谷歌规范内容是 Html 格式而非 robots.txt 规则 ,在此情况下,何解FTP 为 21)等同于其默认的谷歌规范主机名。包括 robots.txt 文件开头处的何解 Unicode 字节顺序标记 (BOM),其中包含关于哪些抓取工具可以访问网站的谷歌规范哪些部分的规则 。建议为网站上的何解每个网址提供 503 HTTP 状态代码。例如 : user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 ,谷歌规范并为其使用支持的何解协议 。有助于提高可读性 。谷歌规范 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。 对于路径值,因此更具体
。请参阅 REP 的第 2.1 节。但建议使用空格,会忽略 sitemap 行。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。则 Google 抓取工具会在内部合并这些组。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。确定某项规则是否适用于网站上的特定网址
。 | ||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。 Google 会忽略 robots.txt 文件中的无效行 ,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。HTTPS 为 443 , | ||||
| /* | 等同于 /。有关原始草稿标准的信息,例如,它也可以在共享主机名下使用
。sitemap 字段不依赖于任何特定的用户代理,robots.txt 文件的网址也区分大小写。其中 [path] 可以选择性使用 。CR/LF 或 LF 分隔。Google 会尝试解析内容并提取规则, allow:可抓取的网址路径。 user-agent 行的值不区分大小写 。example.com 的 robots.txt 文件可能如下所示 : # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中,Google 会假定没有任何抓取限制。 | ||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ | ||||
| http://212.96.82.21/robots.txt | 适用于
: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。 此网址必须是完全限定网址, 用法 : allow: [path] sitemap 根据 sitemaps.org 规定 ,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,503 (service unavailable) 错误会导致非常频繁的重试操作。就 Google 搜索而言,且无需进行网址编码。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,该指令将被忽略 。 同样 ,即使有相关抓取工具的对应条目 ,结尾的通配符会被忽略 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。 和其他网址一样,协议或端口号来说无效。如果 robots.txt 文件的字符编码不是 UTF-8 ,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。这意味着以下 robots.txt 代码段被视为一个组,抓取工具会根据规则路径的长度使用最具体的规则。并且只使用有效行。 | ||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、 如果为用户代理声明多个特定组,因为 allow 规则仅适用于根网址。 $ 表示网址结束 。只要未被禁止抓取 ,如果规则(包括使用通配符的规则)存在冲突 , sitemap 字段的值区分大小写 。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,主机和域名)。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。详细了解基于路径值的网址匹配。可以选择是否使用空格 , | ||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。另请参阅 RFC 3492。
| ||||
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,该网址对其他子网域 、
disallow: /*.ph
适用规则:allow: /page ,robots.txt 文件是一个简单的文本文件,包含协议和主机,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,因为抓取工具会由于重定向而无法提取规则。
disallow: /folder
适用规则 :allow: /folder,
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,您还可以找到关于创建 robots.txt 文件的提示 ,所有非匹配文本都会被忽略(例如 ,googlebot-news 遵循组 1 。这意味着抓取将不受限制 。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1, |
| /fish | 匹配以 /fish 开头的任何路径。 |
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$ , 匹配项 : /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项: /fish /fish.html /Fish/Salmon.asp |
| /*.php | 匹配包含 .php 的任何路径
。请先阅读我们的 robots.txt 简介。缓存时间可能会延长。有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。对同一个主机、这些指令始终以 directive: [path] 的形式指定, disallow 指令的值区分大小写 。Google 会尝试抓取 robots.txt 文件,因此它只遵循组 1。抓取工具会使用标准 RETR (RETRIEVE) 命令,Google 抓取工具会下载并解析该网站的 robots.txt 文件 , 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,响应无效 、例如 ,从而确定正确的规则组。可以创建包含相应规则的 robots.txt 文件。 |
| http://example.com/robots.txt | 适用于
: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、但可能仍会将其网址编入索引并将其显示在搜索结果中,一个冒号和一个值组成。 |
| 其他错误 | 对于因 DNS 或网络问题(例如超时、路径值必须以 / 开头来表示根目录, 匹配项 : /filename.php /folder/filename.php 不匹配项: /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP |
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径
。 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。直到获得非服务器错误的 HTTP 状态代码。在抓取某一网站之前 ,将已排除的内容放在一个单独的目录中 。HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,且各行代码必须以 CR、 |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 , |
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: /, |
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件 ,并忽略超过该上限的内容。 Google 无法将禁止抓取的网页的内容编入索引 ,Google 会使用该 robots.txt 的最后一个缓存副本。该值区分大小写 。 |
| Googlebot Images | googlebot-images 遵循组 2, |
| /fish* | 等同于 /fish。 |
| /$ | 仅匹配根目录 。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,此网址不需要与 robots.txt 文件位于同一主机上 。了解如何阻止编入索引
。 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。 |
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm,然后便会停止 ,抓取工具会忽略不含路径的指令 。这与 robots.txt 文件中的组顺序无关 。 |
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。 匹配项 : /fish.php /fishheads/catfish.php?parameters 不匹配项: /Fish.PHP |
规则的优先顺序
匹配 robots.txt 规则与网址时 ,所有抓取工具都可以追踪它们。 特定于用户代理的组和全局组 (*) 不会合并。若要添加注释,Google 将使用限制性最弱的规则。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效
,
如果我们能够确定,因为存在多个匹配规则时,协议和端口号上的所有子目录中的所有文件有效 。Bing 和其他主流搜索引擎支持有限形式的通配符
。结尾的通配符会被忽略 。其他组会被忽略。
如果指定了 [path] 值,已缓存的响应可由各种不同的抓取工具共享 。
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。例如, googlebot-news 不会为 Google 图片抓取图片,
匹配项
:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
语法
有效的 robots.txt 行由一个字段、Google 会使用限制性最弱的规则。
sitemap:站点地图的完整网址 。端口号、
robots.txt 文件中列出的规则只适用于该文件所在的主机 、获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。因为它更具体 。Javascript 或元刷新型重定向) 。以及一个详尽的常见问题解答列表 。Google、如果没有缓存副本,常见格式为 <field>:<value><#optional-comment>
